26

(12 replies, posted in Showkase Support)

Additional notes:

I tried having only the Large selected (2048x1536)...

Showkase will always generate a medium size image in additional to the optional large and small size images.
You'll notice the Large and Small checkboxes read 'Large images' and 'Small images' respectively whereas the Medium checkbox reads 'Medium image resize'.

If, in the 'Multi-Size Images (Pro)' section, you have only the Large checkbox selected, then Showkase will generate a medium size image according to the settings in the upload module and a large size image according to the settings in the 'Multi-Size Images (Pro)' section.
When Juicebox displays the gallery, the medium size image will be used for the regular gallery display and the large size image will be used when the image is opened in a new window or downloaded.
You can check out the logic for which images are used in a multi-size image gallery here.

If you deselect all three checkboxes in the 'Multi-Size Images (Pro)' section ('Large images', 'Medium image resize' and 'Small images'), then Showkase will generate just one image for the gallery (according to the settings in the upload module) and, as there are no other image sizes available, Juicebox-Pro will have no option but to display this image in the gallery (and also use it for when the image is opened in a new window or downloaded).

Incidentally, it is always the medium size image dimensions that are displayed on the 'Images' tab.

I hope this helps to further explain how things work.

27

(12 replies, posted in Showkase Support)

However, one change I do see is that the Images tab for the page now does show that the images are the correct dimensions there.

That's a step in the right direction.

It just doesn't show it when viewing a gallery.

How are you determining the dimensions of the images being displayed in the gallery? Are you using your browser's developer tools?

By default, Juicebox-Pro dynamically scales images to fit within the bounds of the gallery's image area and it can be hard to tell at a glance what the actual dimensions of a gallery image are.
If you want Juicebox-Pro to display an image at its actual size (without any dynamic scaling), then set imageScaleMode="NONE" (in the 'Main Image (Pro)' section of the gallery's page settings). However, unless you have a fixed size gallery whose dimensions match those of the images, the images may not fit well within the gallery without any dynamic scaling and are likely to be cropped.

In any case, if things don't look as expected when you view your gallery after making any changes, try completely clearing your browser's cache before reloading your web page to ensure that your browser is using the current files from your web server (instead of older, cached versions).
Caching can certainly be useful but it can also sometimes be a hindrance to development.
Maybe this accounts for what you are seeing.

28

(12 replies, posted in Showkase Support)

It sounds like you might be using multi-size images.
Check your settings in 'Site -> Customize Viewers -> Juicebox-Pro (Edit) -> Pro Viewer Options -> Multi-Size Images (Pro)'.
The default values are for the 'Large images', 'Medium image resize' and ''Small images' checkboxes to all be deselected (and for just a single image size to be used).
Try deselecting the 'Medium image resize' checkbox (if it is selected) or increase its pixel values. (The 'Medium image resize' checkbox in the 'Multi-Size Images (Pro)' section overrides the 'Resize images' checkbox in the upload module.)
Sorry I did not think of this earlier (it is not switched on by default).
I hope this helps to explain what you are seeing.

29

(1 replies, posted in Showkase Support)

The Photoshop script for Juicebox only contains Lite options (even if the Pro 'jbcore' folder is present within the script's files).
If you want to configure a gallery created by Photoshop with Pro options, you'll need to do so with JuiceboxBuilder-Pro (or by editing the gallery's 'config.xml' file manually) afterwards.

As long as the Pro 'jbcore' folder is present within the script's files though, your galleries will be Pro (with no branding and no image limit).

For reference, JuiceboxBuilder-Pro and the Juicebox-Pro plugin for Lightroom both have full support for all Pro options in their respective interfaces.

30

(12 replies, posted in Showkase Support)

That sounds odd.
Unfortunately (or rather, fortunately), I cannot replicate this.

As a test I have just uploaded a 2048 x 1536 image using the upload module in Showkase v1.7.5 (set to HTML 5).
I first uploaded the image with resize dimensions of 2048 x 1536 (the same as the original image) and the 'Resize images' checkbox selected.
I then uploaded the same image with the 'Resize checkbox' deselected.
The resulting images on the web server both had the same dimensions of 2048 x 1536 (as expected).

Here are a couple of tips which might help.

(1) If the 'Resize images' checkbox is selected, make sure that the 'Max height' is large enough to accommodate the 'Max width' that you want.
If you set the 'Max width' to 2048 (for example) but set a low 'Max height', then the image may be scaled with the 'Max height' value being the controlling factor and the actual width of the resulting image may be below the 'Max width' value.

(2) If you deselect the 'Resize images' checkbox, then the images you upload will not be resized at all (and will, therefore, retain their original dimensions).

I hope this helps.

31

(8 replies, posted in Showkase Support)

You're welcome!

Thank you very much for your kind words and for the update.
I appreciate you taking the time to let me know that your Showkase site is back up and running. I'm very happy to hear that your problem has been resolved.

I hope that everything goes smoothly in the future but, if you encounter any further problems, just post back here in the forum and I'll do my best to help you out.

I'll mark this thread as [SOLVED].

All the best!

32

(8 replies, posted in Showkase Support)

[Conversation continued via email.]

33

(8 replies, posted in Showkase Support)

Delving into the Showkase source code, it looks like the problem is that NULL is being returned when the JSON string used for the tree on the 'Pages' tab is run through the PHP json_decode function.
What I don't know at this point is why this is happening in your site (i.e. why your site's JSON string cannot be decoded). I cannot replicate this problem with my own test sites.
When I'm able to see the actual JSON string that your own site uses, I should hopefully be able to advance the investigation and figure out why it cannot be decoded. Maybe there's a syntax problem with Showkase's formatting of the JSON string or maybe what should be a JSON string is NULL before decoding is attempted or perhaps there's even a bug relating to the json_decode function in PHP 5.3.19 (unlikely, but in the absence of knowing what is causing the problem, I'll not rule anything out quite yet).

34

(8 replies, posted in Showkase Support)

Thanks Stephen,

You're welcome!

Am working my way down your list, however downloading website is 6-8 hours!

A full backup shouldn't really be necessary but better to be safe than sorry!

Is your email address at showkase dot-net or dot-com?

steven at simpleviewer dot net (or steven at juicebox dot net)

Php version is Php 5.3.19

Thank you for the information. PHP 5.3.19 should be fine. (Showkase requires PHP 5.2.0 or later.)
I'm really not sure why the problem has not occurred until now. If the problem started recently, then it is certainly possible that something might have changed on your web server to cause the problem.
In any case, when I get your email, I'll investigate further.
Thank you.

35

(8 replies, posted in Showkase Support)

I'm sorry to hear that you are having difficulties with Showkase.

Unfortunately, this is not an error that I've encountered before (wither personally or via a user report) so, at the moment, I do not know what might be causing it.

Has anything changed on your web server (e.g. PHP version) recently which might somehow be contributing to your problem?

What version of PHP does your web server use? Do you have the option of updating it? If so, it might be worth trying. (The current stable version is PHP 7.4.12.)

Before trying anything, please make a full backup of your current site, just in case anything further goes wrong and you need to reinstate your files at a later date.

It sounds like the error is a server error (rather than specifically a Showkase error) but I'd try running Showkase in debug mode in case any more descriptive error messages are displayed in the Showkase status bar before the JSON error occurs.
Open your 'showkase/admin/settings/constants.php' file in a plain text editor and change line 12 from:

define('DEBUG', false);

... to:

define('DEBUG', true);

Please note that the line number above refers to the current version of Showkase (v1.7.5).

If you have recently upgraded to Showkase v1.7.5, then I'd also try going through the upgrade process again (with the same v1.7.5 files) to ensure that all Showkase core files are present and correct on your web server (in case anything went wrong during the initial upgrade process resulting in corrupt or missing files).

One more thing I'd try is to go to 'System -> Repairs -> Repair' (in Showkase's interface) to rebuilt the page records.

If none of the suggestions above work, then the best course of action would be to determine the exact nature of the problem.
If you can access your web server error logs, then there should be an entry corresponding to the JSON error which might hopefully let us know exactly what Showkase file (and what line of code within the file) is causing the error.
Please let me know what your error log records for the problem.

I hope these notes help.
Please let me know how you get on and if I can be of any further assistance.
I'd be happy to help further might it would be helpful if I had access to your web server and Showkase site so that I can reproduce the error for myself and investigate further.
If you continue to experience difficulties and are agreeable to allowing me access, then please email me (my email address is below my username to the left of this post) with your FTP and Showkase login details. (I believe that I have previously logged into your web site a while ago.)
Thank you.

36

(1 replies, posted in Showkase Support)

Showkase does not come with its own built-in cookie consent code but you'll find there are many websites that provide cookie consent code that you can use in your own website. (Try a web search for "cookie consent code" and you should find a few.)

You can then incorporate the code into your Showkase site by following the instructions in this forum thread (where another user posted a similar query to yours).

I hope you find the information in the forum thread useful.
Please let me know how you get on and if I can be of any further assistance.
If you experience any difficulties, then please let me know the code you are trying to use (or provide a link to the website that provides the code) and I'll do my best to help further.
Thank you.

37

(3 replies, posted in Showkase Support)

I'm glad you've got it working. Thanks for letting me know!

38

(3 replies, posted in Showkase Support)

You can create Juicebox-Pro galleries directly within the Showkase interface.
Please see the Getting Started support section for details.

However, you could also create your galleries with JuiceboxBuilder-Pro and import them into your Showkase site using Showkase's 'Site -> Import' functionality.
Here is the procedure:

(1) Create a Juicebox gallery on your computer with JuiceboxBuilder or the Lightroom plugin.
(2) Upload the complete gallery folder (not just its contents) to your web server using an FTP program (such as Filezilla). (I recommend uploading it to a location outside your Showkase directory if possible, just to keep things separate from each other.)
(3) Go to 'Site -> Import' in your Showkase site.
(4) For the 'Import path', enter the path to the directory containing the gallery folder (not the gallery folder itself) with a leading slash '/' to denote your root directory.
(5) Click 'Scan' and select the checkbox (in the 'Import' column) next to the gallery folder (or folders - you can import several galleries at once if they are all in the same parent directory) that you'd like to import.
(6) Click 'Import' and 'Publish'.

Once a gallery has been imported, it becomes a genuine Showkase page (just as if the gallery had been created in Showkase itself) and it can be edited from within the Showkase interface if necessary.

You can upload the gallery folder to anywhere you like on your web server as long as the import path is correct.
For convenience, I'd recommend just uploading the gallery folder to your root directory. You would then just use a single slash '/' as your import path.

Incidentally, after importing a gallery, it is safe to delete the original gallery folder that you uploaded for import as Showkase will have copied all the gallery files across to the Showkase site. (Showkase does not automatically delete the gallery folder as it may be part of a different active site.)

I hope this helps.

39

(3 replies, posted in Showkase Support)

I'm glad to hear that you've been able to resolve your problem.
Thank you for letting me know. It's most appreciated.
I hope everything runs smoothly from now on!

40

(3 replies, posted in Showkase Support)

I'm sorry to hear that you are having trouble setting up Showkase on your web server.
Unfortunately, the error 500 that you have encountered is a rather generic server error which does not really help pinpoint the exact cause of the problem.
The problem may be due to a certain PHP function on your web server having been disabled but the error message does not tell us what this might be.
If possible, please check your server error logs (or ask your web host) to try to find out exactly which Showkase script is triggering the error message (and at which line in the script the problem occurs).
If you can find out exactly which PHP command within the Showkase source is causing the problem, then we'll know what the problem is (and, hopefully, how to fix it).
Please post back to let me know how you get on and, with a little more information, I should hopefully be able to help further.
Thank you.

41

(1 replies, posted in Showkase Support)

Hi! Welcome to the forum!
I hope you find everything you are looking for here in the forum and in the online support section.
If you run into any problems using Juicebox, just post here in the forum and I'll do my best to help you out.
I wish you well with Showkase!

42

(7 replies, posted in Showkase Support)

@petax

I'm really glad that you've been able to find the solution to your problem here in the forum (and that the fix was an easy one).
Thank you for sharing your experience!

Incidentally, according to this web page, the default value for max_input_vars is 1,000 so it looks like your web host was just using the default value (rather than purposely choosing a low value).

In any case, I'm happy to hear that your Showkase site is running well!

43

(5 replies, posted in Showkase Support)

OK, I'm glad everything is well! Thank you for letting me know.

I'll mark this thread as [SOLVED] but I'll not lock the thread so please post back if you have any further problems.

44

(5 replies, posted in Showkase Support)

Can I hidden the "about" navigation at the top,

You can hide an 'About' page by dragging and dropping the page name onto the 'Hidden pages' section on the 'Pages' tab (and then clicking 'Save' and 'Publish').

but keep the navigation icon at the footer ?

I'm not sure what you mean. Can you explain in greater detail what navigation icon you are referring to (please provide a link to your web page or a screenshot if possible)?
The Kosel and Maribo themes both have a top navigation menu and the Boma theme has a side navigation menu.
I'm not sure if you are referring to the social media icons in the page footer or a custom link in the page footer (or something else) but hiding a page from the navigation menu (by dragging and dropping the page name onto the 'Hidden pages' section) has no effect on any links in the page footer.

45

(5 replies, posted in Showkase Support)

Yes. You can hide pages (of any page type under any theme) by dragging the pages onto "Hidden pages" (just above "Trash") on the 'Pages' tab (and then clicking 'Save' and 'Publish').
When a page is hidden, there will be no link to the page within the site's navigation menu but the page will still exist within the site so you can use the page's URL as you wish (e.g. send it to someone, use it as a link in another web page, etc.).

46

(1 replies, posted in Showkase Support)

Hi.
Thanks for your query!

Showkase and Juicebox are, indeed, still actively being developed and supported (although it certainly has been a while since the last release of either product).

The next versions of both will likely be bugfix releases (rather than major new versions introducing new features) but, unfortunately, I really do not know when this might be and any estimate I give could turn out to be wholly inaccurate.

I'm sorry I cannot give you any more news at the moment (like what to expect in the next versions or when they will be released).
All I can do just now is reassure you that both products are still alive and kicking!

47

(3 replies, posted in Showkase Support)

You're welcome!

48

(3 replies, posted in Showkase Support)

Yes. The current version of Showkase (v1.7.4) supports all versions of PHP from 5.2.0 up to the current version 7.4.1.
There are no known issues when running Showkase v1.7.4 under PHP 7.3 or 7.4.1 (or any version of PHP above 5.2.0 for that matter).
If you encounter any PHP related issues, please let us know here in the forum. Thanks!

49

(1 replies, posted in Showkase Support)

Unfortunately, the Showkase Server Compatibility Test cannot check for every PHP function used by Showkase. (It checks for the most likely causes of problems.)

It sounds like your web host might have disabled the parse_ini_file PHP function: https://www.php.net/manual/en/function. … i-file.php

Showkase requires this PHP function to be enabled and there is no way to run Showkase without it (and no alternate version of Showkase which does not use it).

Please contact your web host and ask if the parse_ini_file PHP function has been disabled on your hosting account and, if so, ask them if they could enable it for you.

I hope this points you in the right direction.
Please let me know how you get on and if I can be of any further assistance.

50

(3 replies, posted in Showkase Support)

I'm glad to hear that you have ben able to track down and resolve your issue.
Thank you very much for posting back to let me know. It's most appreciated.