51

(3 replies, posted in Showkase Support)

Please try installing and running the Showkase Server Compatibility Test.
Even if you ran the test before originally installing Showkase, please try again in case your web host has made any changes recently which might be contributing to your problem.
The results of the tests may point us in the right direction and let us know the exact nature of the problem.
There are troubleshoting tips on the test's web page (link above)

If everything was working well previously, then please contact your web host and ask if they have made any changes to your hosting account recently which might somehow be contributing to your problem.

Also, if you are not already using the latest version of Showkase (v1.7.4), please try upgrading to see if this helps to resolve your problem.
If necessary, full instructions for downloading the latest version and upgrading an existing site can be found on the Upgrading Showkase support page.

I hope this helps (at least as a starting point to figuring out what is causing your problem).
Please let me know how you get on.
Thank you.

You're welcome.
I hope it works for you!

Thank you for the update and additional information.

at first it was helpful, the missing picture is shown in the gallery after deleting the browser cache ..

This certainly suggests that the problem has been a browser cache issue. (As you are aware, clearing your browser's cache does not change anything on the web server and, if clearing your browser cache has resulted in you being able to see what you expect to see, then the files must have always been present and correct on the web server.)

it happens only - and everytime .. in galleries of the first gallery index page

Weird, indeed...

Here are a couple of things you could try to prevent browsers from caching your Showkase web pages.

Suggestion #1:
If you want to prevent browsers from caching Juicebox gallery XML files, then try defining the gallery XML files with a unique identifier (e.g. the current time which will be different each time the browser loads the page) via the configUrl option in each gallery's embedding code.

Open your 'showkase/_themes/base/pagetypes/juicebox.tpl' file in a plain text editor and change line 26 from:

baseUrl : '{$ss_pageUrl}/'

... to:

baseUrl : '{$ss_pageUrl}/', configUrl: 'config.xml?nocache=' + new Date().getTime()

Now republish your site for this change to propagate throughout all your Showkase Juicebox galleries.

Suggestion #2:
You may also be able to dissuade browsers from caching HTML pages by using certain <meta> tags.

Open your 'showkase/_themes/base/pagetypes/basetheme.tpl' file in a plain text editor and add the following code in the {block "meta"} ... {/block} section, between lines 9 and 23 (but not inside {if $ss_ogImageUrl ne ''} ...  {/if}).

<meta http-equiv="cache-control" content="no-cache" />
<meta http-equiv="expires" content="0" />
<meta http-equiv="pragma" content="no-cache" />

Again, republish your site for this code to appear in all your Showkase pages.

if you give me your email...

If you ever need to contact me via email my email address is below my username here in the forum (visible only when you are logged in).

I hope my notes above help.

@ferdinand

I'm glad you've found a way to achieve what you were looking to do.
Thank you for sharing!

It sounds like a browser caching issue.
Instead of just refreshing the web page (with 5/Ctrl+F5), try completely clearing your browser's cache before reloading the web page (or at least try viewing the web page in a browser that you have not previously used to view the web page to check whether or not it is a browser caching issue).
This should hopefully solve your problem.
However, if the problem persists, then please post back with the URL to the web page in question and let me know what you see (e.g. how many images) and what you expect to see.
I'll let you know what I see in my own browser and investigate further.
Thank you.

56

(3 replies, posted in Showkase Support)

I'm glad you've got it working again!
Thank you for letting me know.

57

(3 replies, posted in Showkase Support)

It sounds like Showkase cannot read or write to the showkaseconfig.ini file so the first thing I'd try is checking the permissions of the file.
You should find the file in this location: showkase_folder/_showkase/showkaseconfig.ini

Check the permissions of both the showkaseconfig.ini file and its _showkase parent folder (with an FTP program such as Filezilla).
Default permissions of 644 for the file and 755 for the folder should be fine (but if this does not work, then try setting full permissions for both the file and folder).

If this does not help, then please try installing and running the Showkase Server Compatibility Test.
Even if you ran the test before originally installing Showkase, please try again as things may have changed on your web server since then.
Instruction scan be found here.
Check out all the test tabs but especially the 'File tests' one which might give us a clue to the nature of the problem.

Please let me know how you get on.
Thanks!

@cocawage

If you are having a problem with Showkase, then you'll really need to give me more to go on than just quoting part of a reply that I have previously given to another user.
It should not come as a surprise that hiding a page will prevent it from being displayed in the Showkase menu.

Please post back with a complete description of your problem (including a link to your Showkase site so that I can see the problem for myself) and I'll try to help you out.
Thank you.

59

(3 replies, posted in Showkase Support)

That's great! Thanks for letting me know.

60

(3 replies, posted in Showkase Support)

Try using a media query using the same breakpoint that Showkase uses to switch between small screen mode and large screen mode.
Try something like the following:

@media only screen and (max-width: 768px) {
    .headings-open-sans h3,.headings-open-sans header nav ul li a {
        /* Custom CSS rules for small screen mode go here */
    }
}

I hope this helps.

61

(6 replies, posted in Showkase Support)

Problem solved via email. (Web hosting file structure issue.)

62

(6 replies, posted in Showkase Support)

Email received, thank you. I've sent you a reply.

63

(6 replies, posted in Showkase Support)

Please post the URL to your Showkase site so that I can take a look at your galleries and files for myself.
I might see something that will help.

Otherwise, it would help if I had access to both your Showkase site and web server so, if you are agreeable to this, please send me your Showkase login details (admin URL, username and password) and FTP login details (host, username and password) and I'll investigate further and hopefully figure out what's going wrong. (You already have my email address.)
Thanks.

64

(6 replies, posted in Showkase Support)

The instructions for Upgrading to Pro should work fine so please try again.

Here's an expanded set of instructions:

(1) Extract the juicebox_pro_1.5.1.zip file to your hard drive and you'll find the Pro jbcore folder in this location: juicebox_pro_1.5.1/web/jbcore (Please double-check that you are using the Juicebox-Pro zip file and not the Juicebox-Lite zip file.)

(2) Navigate to the showkase/admin/plugins/juicebox/master/ directory on your web server and delete the existing jbcore folder there (showkase/admin/plugins/juicebox/master/jbcore). (This saves you from having to check if your FTP program is set to overwrite existing files in Step #3 below.)

(3) Upload the jbcore folder from Step #1 above (juicebox_pro_1.5.1/web/jbcore) to the showkase/admin/plugins/juicebox/master/ directory on your web server.

(4) Republish your site (click the 'Publish' button). (Juicebox galleries within a Showkase site are not updated until the site is republished.)

(5) Clear your browser's cache before reloading your gallery pages. (This will ensure that your browser is not still using older cached files from prior to the republishing.)

Incidentally, if you are not already using the current version of Showkase (v1.7.4), then please upgrade. There was a bug (which was fixed in v1.7.4) which prevented the correct version of Juicebox being displayed in 'Site -> Customize Viewers' and 'Site -> Change Viewers'. (This did not affect any functionality but could be confusing.)
Full instructions can be found on the Upgrading Showkase support page.
For reference, a list of changes between version can be found on the Version History page.

I hope this helps.

65

(3 replies, posted in Showkase Support)

You're welcome!
I'm glad to hear that everything is working OK now.
Thank you for letting me know.

66

(3 replies, posted in Showkase Support)

That's odd. I've not encountered this problem myself and, as far as I can recall, no-one else has reported such a problem before (non-functioning 'Start Upload' button) so I'm not sure what might be causing your problem.
However, here are some troubleshooting tips which might help.

(1) Upload Mode
Try using a different upload mode. The default upload mode is 'HTML 5'. Try changing it to 'Basic' to see if this makes a difference.
You can toggle between upload modes via the blue link at the bottom-right corner of the upload module.

(2) Different Images and Resize Settings
Try uploading images from a difference source (perhaps just some sample images from the internet) to see if they upload OK (and to determine if the problem is somehow unique to the images that you are using).
Try also using different resize settings to see if this makes a difference.

(3) Clear Browser Cache or Try Different Browser
Try clearing your browser's cache before reloading your site's dashboard or access your Showkase site using a different browser. This is a bit of a long shot but in the absence of knowing exactly what is causing your problem, I would not rule anything out yet and this is a quick and easy thing to try (and it might make a difference).

(4) Run the Showkase Server Compatibility Test
Try running the Showkase Server Compatibility Test to see if any of the tests fail.
Even if you ran the test before initially installing Showkase, please try again in case your web host has made any changes recently which might be contributing to your problem. The results of the tests might point us in the right direction.
There are troubleshooting tips for any tests that fail on the compatibility test's support page (in the link above).

(5) Upgrade (or Reinstall) Showkase
If you are not already using the latest version of Showkase (v1.7.4), then try upgrading following the Upgrading Showkase instructions.
Even if you are already using the latest version, try reinstalling it (just follow the upgrading instructions but with your currently installed version) to ensure that all core Showkase files are present and correct on your web server (in case something happened during the initial upload resulting in an incomplete or corrupt installation).

(6) Upgrade PHP
I do not know what version of PHP your web server has installed (please let me know) but, if possible, upgrade to the latest version available to you in case this helps (current version is PHP 7.3.6). You might be able to change the version of PHP that your web site uses via your web host's online control panel.

(7) Run Showkase in Debug Mode
Try running Showkase in debug mode to see if any error messages or warnings are displayed in the application's status bar which might help to pinpoint the cause of the problem.
Open your 'showkase/admin/settings/constants.php' file in a plain text editor and change line 12 from:

define('DEBUG', false);

... to:

define('DEBUG', true);

Please note that the line number above refers to the current version of Showkase (v1.7.4).

(8) Check in with your Web Host
If the problem has only started to happen recently and you have not changed anything yourself, then this suggests that something might have changed on your web server.
Please ask your web host to see if they have made any changes recently which might be affecting your hosting account (and, subsequently, Showkase's functionality).

I hope these suggestions point you in the right direction.
Please let me know how you get on and if I can be of any further assistance.

I would be happy to help further but I'd really need access to your web server in order to investigate the problem.
If you are agreeable to this (and my suggestions above do not help), then please let me know (post back here) and I'll send you an email address which you can use to forward your FTP login details to me. Thank you.

Edit:
Just another thought...
Is there any chance you could please provide your PHP settings?
You should be able to check your PHP settings using phpinfo() as follows:
(1) Create a new file in a plain text editor with the following code: <?php phpinfo(); ?>
(2) Save the file with a .php file extension (for example, 'phpinfo.php').
(3) Upload the file to your web server and open it in a browser. Please also post the file's URL here in the forum so that I can check your PHP settings myself.

With the above in mind, please check that your PHP post_max_size is at least as large as your PHP upload_max_filesize and that your PHP memory_limit is at least as large as your PHP post_max_size.
Here's a quote from the PHP documentation regarding post_max_size.

post_max_size integer
Sets max size of post data allowed. This setting also affects file upload. To upload large files, this value must be larger than upload_max_filesize. Generally speaking, memory_limit should be larger than post_max_size.

67

(5 replies, posted in Showkase Support)

You're welcome!

68

(5 replies, posted in Showkase Support)

Sorry, I missed that part of your query.

The 'Base font size (px)' can be set only for the entire site in the 'Site -> Customize Theme -> Fonts' section.
There is only one setting for consistency throughout the site.

If you want to change the font size for one page only, then you'll need to do so via CSS (by adding custom CSS to your theme's 'custom.css' file).

First of all, you'll need to find the page number for the page whose font size you'd like to change.
Open the source of the page in a browser, scroll down to the opening <body> tag and check the 'page-xxx' CSS class.
In your case, your page's body tag is as follows:

<body class="light type-basic page-10 group-0  body-arial headings-helvetica ">

... and the page number is 'page-10'.

Now you can target the page using this CSS class.

Next, open your '/_themes/kosel/css/custom.css' file and add the following CSS to change the font size of the body text (changing the font size value as appropriate).

.page-10 {
    font-size: 24px;
}

If you want the font size to be applied to only the body content text (and not the 'Page title' or footer), then use the following CSS instead:

.page-10 .body-content {
    font-size: 24px;
}

Incidentally, if you use a theme other than Kosel, then to find the location of the 'custom.css' file, just replace 'kosel' with the lower-case name of the theme you use (e.g. 'boma', 'maribo') in the path '/_themes/kosel/css/custom.css'.

I hope this helps.

69

(5 replies, posted in Showkase Support)

The default 'Body text layout' for all Showkase pages is "1-column narrow".

Edit your page, scroll down to (and expand) the 'Override Site Options' section and change the 'Body text layout' from "1-column narrow" to "1-column wide". Now click 'Save' and 'Publish'.

Hopefully this will solve your problem.

70

(3 replies, posted in Showkase Support)

I'm glad you've got it working.
Thank you for posting back to let me know.

71

(3 replies, posted in Showkase Support)

When you see the blank page, what is the URL in the browser (what is the address of the blank page that you are viewing)?
What do you see when you view the source of the blank web page in your browser (maybe there is a clue to the nature of your problem hidden in the code of the blank page)?

The first thing I would try is re-uploading all the core Showkase to your web server in case something happened during the initial upload which has resulted in an incomplete site (maybe not all files were uploaded) or corrupt files.

Does your web server have any error logs that you can look into to see if you can figure out what went wrong?

If delving deeper into the origin of the blank page, re-uploading Showkase to your web server and checking your web servers error logs does not help, then it might help to know more about your web server.
Does your web server run Linux or Windows?
What version of PHP does your web server have installed (please check that it is installed and working correctly)?
What version of Showkase are you using?

Perhaps you could post a link to your Showkase Server Compatibility Test (so that I can take a look at the results for myself) and also post a link to your PHP settings (as noted below).
(1) Create a new file in a plain text editor with the following code: <?php phpinfo(); ?>
(2) Save the file with a .php file extension (for example, 'phpinfo.php').
(3) Upload the file to your web server and post its URL here in the forum so that I can check it out.

With a little more information, we should hopefully be able to determine the cause of your problem.
Thank you.

72

(3 replies, posted in Showkase Support)

You're welcome. Sorry it's not the response you were hoping for.
It still might be worth posting in the Feature Requests thread though.

73

(3 replies, posted in Showkase Support)

Unfortunately, as far as I am aware, there is no quick and easy way to create a gallery index page with a single column of thumbnails.
If I knew of a solution, I'd happily share it with you but the variable which handles the 'Max thumb columns' appears in seven different source files and I do not know the formulae that the author used to generate thumbnail dimensions and breakpoints.
It is probably much more complicated that it looks at first sight.

Perhaps you could post your suggestion in the Feature Requests forum thread.
This keeps all the ideas together and ensures that they are not overlooked by the developers.
I do not know the likelihood of any ideas being implemented in future versions but this is certainly the best place for all ideas.
Thank you.

OK, thank you for the update. Please let me know how you get on.
(I still cannot replicate the problem you describe so it could be a server-specific problem such as some sort of caching issue.)

If you create a new Juicebox gallery page, it should appear on the gallery index page as soon as you drag and drop the Juicebox gallery page onto the gallery index page (on the 'Pages' tab) and click 'Save' and 'Publish', even if it is the only gallery page grouped under the gallery index page.
If you have not yet edited the Juicebox gallery page (for example to add images to the gallery), then the Juicebox gallery page will still be represented on the gallery index page but the gallery index page will just display a 'no images' icon (a white cross on a grey background) as a thumbnail image for the gallery.

If this does not seem to happen within your Showakse site, then maybe there's some kind of caching issue causing the problem (whether due to server-side caching on your web server or client-side caching in your web browser.)
Check with your web host to see if caching is used on your hosting account and try clearing your web browser's cache before previewing your gallery index page.

I can't be sure that this will solve your problem but I hope that it points you in the right direction.

Incidentally, I've tried unsuccessfully to replicate the problem you describe in a fresh Showakse v1.7.4 site.
A single Juicebox gallery page always appears on a gallery index page (whether I have uploaded images to the gallery or not) and without the need to add another gallery page to the gallery index page.