Topic: Text layout [SOLVED]

Hi!

Why text layout is so strange on basic-type page? All the text is on the left side.
And how can I change font size only at this page? Thanks.

http://vasilyiakovlev.com/osen-v-yuzhnoj-moravii-2019/

https://2.downloader.disk.yandex.ru/preview/6dd26492b02eacb721f999ee75cf2a3572b63de492309331a03d9b62c744676c/inf/DMHSUtiIZGrNuPQ78pR79iSSCOONxLbNMByvNDavvXEzQZ_h0NutBqub9APeEanjcDeMpMLImSSth4_CT5Hysg%3D%3D?uid=15832793&filename=2019-06-06_16-02-00.jpg&disposition=inline&hash=&limit=0&content_type=image%2Fjpeg&tknv=v2&size=1863x938

Re: Text layout [SOLVED]

The default 'Body text layout' for all Showkase pages is "1-column narrow".

Edit your page, scroll down to (and expand) the 'Override Site Options' section and change the 'Body text layout' from "1-column narrow" to "1-column wide". Now click 'Save' and 'Publish'.

Hopefully this will solve your problem.

Re: Text layout [SOLVED]

Thanks so much, it helped!
And how can I change font size only at this page? Thanks.

Re: Text layout [SOLVED]

Sorry, I missed that part of your query.

The 'Base font size (px)' can be set only for the entire site in the 'Site -> Customize Theme -> Fonts' section.
There is only one setting for consistency throughout the site.

If you want to change the font size for one page only, then you'll need to do so via CSS (by adding custom CSS to your theme's 'custom.css' file).

First of all, you'll need to find the page number for the page whose font size you'd like to change.
Open the source of the page in a browser, scroll down to the opening <body> tag and check the 'page-xxx' CSS class.
In your case, your page's body tag is as follows:

<body class="light type-basic page-10 group-0  body-arial headings-helvetica ">

... and the page number is 'page-10'.

Now you can target the page using this CSS class.

Next, open your '/_themes/kosel/css/custom.css' file and add the following CSS to change the font size of the body text (changing the font size value as appropriate).

.page-10 {
    font-size: 24px;
}

If you want the font size to be applied to only the body content text (and not the 'Page title' or footer), then use the following CSS instead:

.page-10 .body-content {
    font-size: 24px;
}

Incidentally, if you use a theme other than Kosel, then to find the location of the 'custom.css' file, just replace 'kosel' with the lower-case name of the theme you use (e.g. 'boma', 'maribo') in the path '/_themes/kosel/css/custom.css'.

I hope this helps.

Re: Text layout [SOLVED]

Perfect, thank you so much!

Re: Text layout [SOLVED]

You're welcome!