Topic: Problem with my site

Hi, guys. It's been a while. My site was fine until something got messed up.

Here is the address so you can see the top menu is not showing up correctly.

If you can't diagnose this, I'm happy to reinstall and try again from scratch. And purchase or upgrade to the latest version of Showkase.

Using Cpanel I can copy folders from online to my desktop, but I'm not sure how I could get that data back, short of importing each image and recreating all the categories.

Re: Problem with my site

I'm sorry to hear that you are having trouble with your Showkase site.
I hope my notes below help.

Checking out the web page you provided a link to, I notice that none of the external CSS and JavaScript resource files are being loaded.
If you try to view one of them directly in a browser (e.g. … styles.css), you'll see the following error message:

You don't have permission to access this resource.
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

This error message suggests that the permissions on the CSS and JavaScript files are too restrictive.
Please check the permissions of your site's CSS and JavaScript files. (Default permissions of 644 should be fine.)
It looks like all your CSS and JavaScript files are affected so it appears that something might have happened on your web server to have caused this problem.
Ask your web host if they have made any changes to your hosting account recently which might be contributing to the problem.
If they have made a change, then perhaps they can reverse it.

Here are some other suggestions...

First of all, please make a complete backup of your site, just in case anything goes wrong and you need to reinstate your original files at a later date. (Even though the site is not currently functioning, a backup might come in useful if you need to rebuild your site.)

Assuming you can log in and navigate around the interface without any CSS, go yo 'System -> Files' and click 'make writeable' against every entry. This should change the permissions throughout your site and might hopefully resolve your problem.

If you need to rebuild your site, there are a couple of things that you can do to reduce the workload.

(1) You can retain the Showkase settings from your original site by manually copying the following files and folders from your original site to your new site (overwriting the default versions which will be in place after a fresh install).

  • _data/sitedata (folder)

  • _data/themedata (folder)

  • _data/pagesprefs.txt (file)

  • _data/theme.txt (file)

Do not copy the _data/pagesdata.txt file though, as this lists the pages present in each site (which will be different after a fresh install).

If you use a custom logo via an image stored in the library, for example, then you might also like to copy the _library folder from your original site to your new site.

If you have modified any Showakse source files or used the custom.css or custom.js files, then please remember that you will need to reinstate your customized files after a fresh install.

(2) You can import all the pages from your original site (via 'Site -> Import') to avoid having to recreate all your pages from scratch. You can import multiple pages at once so recreating your original site should be relatively quick and easy. (You'll need the page folders from your backup to do this.)

Just in case you need a new Showkase-Pro download link, I've emailed you a new one so you can downland the latest version (v1.7.5).

Having said al of the above, it looks like all the CSS and JavaScript files are in their correct locations on your web server but just not being loaded due to a permissions problem.
I am hopeful that your web host will be able to help you fix the problem quickly and without too much effort.

If you run into any difficulties trying to explain things to your web host, just ask them why trying to view this file: … styles.css
... results in an error 403 when this has not always been the case and what might have caused this problem (as I'm quite you you didn't go changing permissions on all CSS and JavaScript files manually yourself).

I hope my notes help and point you in the right direction.

Re: Problem with my site

Dear Steven: Thanks for your quick reply. If necessary, you've given me a recipe that will allow me to start from scratch but return my settings.

It was permissions! However, the only way I can get it to function is to make all file and folder permissions be 777, which we know is dangerous. 666 does not work, 664 does not work . 644 does not work. If I recall, Some combination of folders set to one permission and files set to another permission can work. What settings do you suggest? Thanks.

4 (edited by bobkatz 2021-03-13 18:46:57)

Re: Problem with my site

I found that I can set it the same as recommended by Wordpress: All folders 755 and all files to 644. This works and I think is the best I can do security-wise.

Re: Problem with my site

Even though I had the permissions right, I was not able to get into the admin page. So I decided to reinstall. The easiest thing was for me to delete the entire bobsgallery folder from ssh. I then recreated the folder. It is a subdomain, hopefully that attribute has been retained.

I then uploaded a new installation using the instructions from readme.html that comes with a new Showkase installation. I uploaded the .htaccess file from my backup.

bobsgallery comes up as a new Showkase site telling me to go to admin to set it up.

But I cannot get into admin:
You don't have permission to access this resource.Server unable to read htaccess file, denying access to be safe

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

Changing permissions of .htaccess to 777 does not help. Clearing Chrome's cache does not help. I'm stuck... so sorry.

Re: Problem with my site

All folders 755 and all files to 644. This works and I think is the best I can do security-wise.

That's fine. These are default values (755 for folders and 644 for files) and Showkase should work fine with them.

With regard to your .htaccess file, Showkase does not require a .htaccess file so try removing it (at least temporarily for testing purposes) to see if this helps.

If it does help but you need to reinstate your .htaccess file for other reasons, then check the permissions of the directory containing the .htaccess file (as well as the .htaccess file itself). Try settings the parent directory's permissions to 755. If the permissions are already 755, then try changing them to something else and then back to 755. (It's worth a shot.)

Otherwise, you might need to ask your web host why your .htaccess file cannot be read (and is preventing other files on your site (your Showkase files) from being displayed.