Topic: Domain location move [SOLVED]

I've had Showkase setup as my main domain with a few other add-on domains each setup through the Showkase admin.
I recently changed what was an add-on to be my main domain. All the folders were moved around on the server with what was the main put into a folder and what was the add-on moved to main html folder (in Bluehost terms, the public_html folder). The site displays fine, but the Showkase admin interface is now messed up. When I first went into the admin page I was prompted to run Setup. When I do that I get these alerts:

    Notice: Undefined index: contentPath
    Notice: Undefined index: absoluteContentPath
    Cannot save to showkaseconfig.ini. Check installation folder permissions.

What's the best way to remedy this with the minimal amount of pain?


Re: Domain location move [SOLVED]

It sounds like Showkase cannot read or write to the showkaseconfig.ini file so the first thing I'd try is checking the permissions of the file.
You should find the file in this location: showkase_folder/_showkase/showkaseconfig.ini

Check the permissions of both the showkaseconfig.ini file and its _showkase parent folder (with an FTP program such as Filezilla).
Default permissions of 644 for the file and 755 for the folder should be fine (but if this does not work, then try setting full permissions for both the file and folder).

If this does not help, then please try installing and running the Showkase Server Compatibility Test.
Even if you ran the test before originally installing Showkase, please try again as things may have changed on your web server since then.
Instruction scan be found here.
Check out all the test tabs but especially the 'File tests' one which might give us a clue to the nature of the problem.

Please let me know how you get on.

3 (edited by mrjw34 2019-11-12 14:18:46)

Re: Domain location move [SOLVED]

The showkaseconfig.ini file and its enclosing folder both had the correct permissions.
As it turned out the .ini file was 0 bytes. 
I replace the file with one from the previous domain setup. I then logged in using the old .ini file in place. Once again I got the prompt that I should run Setup. This time running it worked!
Everything is in order and I re-published.
Seems like it's all good.

Thanks for the help Steven!

Re: Domain location move [SOLVED]

I'm glad you've got it working again!
Thank you for letting me know.