Topic: The "Start Upload" button doesn't run [SOLVED]


It's impossible to upload images to a juicebox o list viewver pages.
There is no message, just the button is not becoming green, and impossible to upload the selected files.
Thanks in advance for your help !

Re: The "Start Upload" button doesn't run [SOLVED]

That's odd. I've not encountered this problem myself and, as far as I can recall, no-one else has reported such a problem before (non-functioning 'Start Upload' button) so I'm not sure what might be causing your problem.
However, here are some troubleshooting tips which might help.

(1) Upload Mode
Try using a different upload mode. The default upload mode is 'HTML 5'. Try changing it to 'Basic' to see if this makes a difference.
You can toggle between upload modes via the blue link at the bottom-right corner of the upload module.

(2) Different Images and Resize Settings
Try uploading images from a difference source (perhaps just some sample images from the internet) to see if they upload OK (and to determine if the problem is somehow unique to the images that you are using).
Try also using different resize settings to see if this makes a difference.

(3) Clear Browser Cache or Try Different Browser
Try clearing your browser's cache before reloading your site's dashboard or access your Showkase site using a different browser. This is a bit of a long shot but in the absence of knowing exactly what is causing your problem, I would not rule anything out yet and this is a quick and easy thing to try (and it might make a difference).

(4) Run the Showkase Server Compatibility Test
Try running the Showkase Server Compatibility Test to see if any of the tests fail.
Even if you ran the test before initially installing Showkase, please try again in case your web host has made any changes recently which might be contributing to your problem. The results of the tests might point us in the right direction.
There are troubleshooting tips for any tests that fail on the compatibility test's support page (in the link above).

(5) Upgrade (or Reinstall) Showkase
If you are not already using the latest version of Showkase (v1.7.4), then try upgrading following the Upgrading Showkase instructions.
Even if you are already using the latest version, try reinstalling it (just follow the upgrading instructions but with your currently installed version) to ensure that all core Showkase files are present and correct on your web server (in case something happened during the initial upload resulting in an incomplete or corrupt installation).

(6) Upgrade PHP
I do not know what version of PHP your web server has installed (please let me know) but, if possible, upgrade to the latest version available to you in case this helps (current version is PHP 7.3.6). You might be able to change the version of PHP that your web site uses via your web host's online control panel.

(7) Run Showkase in Debug Mode
Try running Showkase in debug mode to see if any error messages or warnings are displayed in the application's status bar which might help to pinpoint the cause of the problem.
Open your 'showkase/admin/settings/constants.php' file in a plain text editor and change line 12 from:

define('DEBUG', false);

... to:

define('DEBUG', true);

Please note that the line number above refers to the current version of Showkase (v1.7.4).

(8) Check in with your Web Host
If the problem has only started to happen recently and you have not changed anything yourself, then this suggests that something might have changed on your web server.
Please ask your web host to see if they have made any changes recently which might be affecting your hosting account (and, subsequently, Showkase's functionality).

I hope these suggestions point you in the right direction.
Please let me know how you get on and if I can be of any further assistance.

I would be happy to help further but I'd really need access to your web server in order to investigate the problem.
If you are agreeable to this (and my suggestions above do not help), then please let me know (post back here) and I'll send you an email address which you can use to forward your FTP login details to me. Thank you.

Just another thought...
Is there any chance you could please provide your PHP settings?
You should be able to check your PHP settings using phpinfo() as follows:
(1) Create a new file in a plain text editor with the following code: <?php phpinfo(); ?>
(2) Save the file with a .php file extension (for example, 'phpinfo.php').
(3) Upload the file to your web server and open it in a browser. Please also post the file's URL here in the forum so that I can check your PHP settings myself.

With the above in mind, please check that your PHP post_max_size is at least as large as your PHP upload_max_filesize and that your PHP memory_limit is at least as large as your PHP post_max_size.
Here's a quote from the PHP documentation regarding post_max_size.

post_max_size integer
Sets max size of post data allowed. This setting also affects file upload. To upload large files, this value must be larger than upload_max_filesize. Generally speaking, memory_limit should be larger than post_max_size.

Re: The "Start Upload" button doesn't run [SOLVED]

Hi Steven,

Today everything is OK, I did'nt do anything. May be some problem with the host... Anyway many thank  for your answer

Re: The "Start Upload" button doesn't run [SOLVED]

You're welcome!
I'm glad to hear that everything is working OK now.
Thank you for letting me know.