1

(4 replies, posted in Showkase Support)

Thank you for the update!
I'm glad you have been able to find the cause of your problem.
Thank you for posting back to let me know. It's most appreciated.

2

(4 replies, posted in Showkase Support)

By default, Showkase uses the first image in the gallery as the representing thumbnail on the gallery index page.
You can choose any gallery image you like for the gallery index page thumbnail as follows:
(1) Edit the gallery page (on the 'Pages' tab).
(2) Go to the 'Images' tab.
(3) Select the image you want as your representing image in the 'Index' column.
(4) Click 'Save' and then 'Publish'.

Please note that if you rearrange the order of images in the gallery, then it will be the original first image (before reordering) that will be used as the representing image (unless you change it as above).

Showkase has no caching functionality built-in at all. Changes are made instantly and you should see them immediately after publishing.

If you do not see changes immediately after making them, then try clearing your browser's cache before reloading your web page (or view your web page in a different browser that has not been used to view the web page before). This should let you know whether browser caching is at the root of your problem.

If this does not help, then it would appear that there is some server-side caching going on that you might need to investigate further.

I hope these notes help.

3

(3 replies, posted in Showkase Support)

You're welcome!

I'm really glad that you've been able to resolve your problem.
Thank you for letting me know. It's most appreciated!

All the best!

4

(3 replies, posted in Showkase Support)

Hello.

The problem is almost certainly a caching issue of some kind.

To make sure that your browser is not caching and displaying the older gallery page, try pressing Ctrl+F5 or, better still, completely clearing your browser's cache before reloading your gallery page.
I know you say that you've already tried this but it's worth trying again as there are no known bugs in Showkase which would result in the issue you describe.

Also, after changing some configuration options, try viewing the gallery page in a different browser, one that has not been used to view the original gallery page (before the changes). This should confirm whether the caching problem is client-side (browser-related) or server-side.

There is a chance that your web host uses server-side caching and even though the files on your web server are being modified by Showkase, older versions of those file could still be served to browsers for a certain amount of time.

I have an account with a web host that uses Varnish server caching. After I upload a new version of a file to my web server, the new version is not seen (and the old version is still served) for about 20 minutes afterwards. For this reason, I have Varnish disabled.

Please check in with your web host to see if they have server-side caching enabled on your hosting account and, if so, ask if they could disable it.

Caching can certainly be useful but it can also sometimes be a hindrance to development.

I hope my notes above help to resolve your problem.
Please let me know how you get on and if I can be of any further assistance.
Thank you.

5

(1 replies, posted in Showkase Support)

I'm sorry to hear that you are having trouble with Showkase.
Unfortunately, an error 500 is a rather generic internal server error and it's not really specific enough to pinpoint the cause of the problem.
However, from the information you provide, the problem could actually be the permissions that you set (777).

777 permissions should work OK but because they are the most relaxed permissions that you can use, some web servers are configured to actually not respect the 777 permissions and, instead, treat them as a potential security risk which, is this is teh case, could certainly prevent Showkase from functioning.

Under normal circumstances on most web servers, there should actually be no need to set permissions of 777.
Showkase should work perfectly fine with default permissions of 755 for folders and 644 for files.

Try changing permissions to 755/644 (or just reupload Showkase using default permissions if it's easier) and see if this helps.

I hope this helps to resolve your problem.
Please let me know how you get on and if I can be of any further assistance.

If you continue to experience difficulties, then please let me know what type of web server you are installing Showkase on (e.g. Linux vs Windows, Apache vs IIS) and what version of PHP your web server has installed and I'll try to help further.

Also, it might help to check out your web server logs to see if anything more specific than an error 500 has been logged that might point us in the right direction.

Thank you.

6

(3 replies, posted in Showkase Support)

You're welcome!

7

(3 replies, posted in Showkase Support)

Just to clarify, are you talking about the tree on the admin interface's 'Pages' tab (and not the navigation menu in the live site)?
As long as that's correct, then here's a suggestion.

Open up your site's 'showkase/admin/classes/pagesscreen.php' file in a plain text editor.

Change line 109 from:

$("#container").jstree({

... to:

$("#container").on("ready.jstree", function(event, data) {
    data.instance.close_all();
    data.instance.open_node("ref0");
}).jstree({

Now re-upload the 'pagesscreen.php' file to its original location on your web server (overwriting the existing file).

This will allow Showkase to build the 'Pages' tree and, once the tree is ready, the custom code will collapse all nodes and then open just the root node ('Public pages') so that you can see only your top-level pages.

I tried changing the state of each node (from open to closed) as Showkase creates the individual nodes but this has the unwanted effect that when you open an initially closed node, the tree registers this as a change. This results in an unnecessary reminder to 'Save' the change when you move to a different admin tab (without actually having made any functional changes to the tree, e.g. moving or renaming a node).
I think my suggestion above is perhaps the best option.

Notes:
(1) The line number above refers to the current version of Showakse (v1.7.6).
(2) Any changes to the Showkase source code should be done at your own risk. I do not foresee any problems with the code above but it would always be wise to make a complete backup of your site before modifying any source code, just in case anything unexpected happens and you need to reinstate your original files at a later date.

8

(11 replies, posted in Showkase Support)

OK, no problem!
Thanks for letting me know.

9

(11 replies, posted in Showkase Support)

Just enter the 'Web Property ID' in the Showkase interface (above the 'Tracking Code' input) and Showkase will handle the Google Analytics code for you (without the need to modify any source code manually).

I noted the basetheme.tpl file only because you mentioned other properties and if you want to add an additional Google Analytics property to the code (such as MEASUREMENT_ID_2 in the sample code provided here), then you would need to do this manually.

If you just want to use the 'Web Property ID', then Showkase can take care of this for you.

10

(11 replies, posted in Showkase Support)

Showkase supports only the Web Property ID. If you need to add any extra parameters to the Google Analytics 4 code, then you'll need to add them manually to the Showkase source code.
Open your showkase/_themes/base/pagetypes/basetheme.tpl file in a plain text editor and you'll find the Google Analytics 4 code staring at line 10.
You can hard-code whatever extra parameters you like within this code and, after republishing your site (just click the 'Publish' button), the extra parameters will appear in the Google Analytics 4 code within all your pages.

11

(11 replies, posted in Showkase Support)

It's probably just a browser caching issue.
Try refreshing the settings page (Ctrl + F5).
Otherwise, try completely clearing your browser's cache before reloading the settings page.
It should look like this screenshot: [Link removed.]

12

(11 replies, posted in Showkase Support)

Links sent!

You can find instructions for Upgrading Showkase here.

Notes:

(1) When upgrading your Showkase site, please be sure to make a complete backup of your existing site first, just in case anything should go wrong and you need to reinstate your original files at a later date. You should not encounter any problems upgrading Showkase but it would be wise to have a backup of your site should anything unexpected happen. Also, if you have made manual customizations to any Showkase source files, then please note that they may be overwritten when you upgrade and you'll need a backup in order to reinstate them afterwards.

(2) Please remember that Showkase-Standard comes bundled with Juicebox-Lite (the free version of Juicebox) so, after upgrading your Showkase site, you'll need to reinstate your Juicebox-Pro files by following the Installing Juicebox Pro instructions here.

13

(11 replies, posted in Showkase Support)

Support for Google Analytics 4 was introduced in Showkase v1.7.5.

If you go to 'Site -> Site Settings' and expand the 'Google Analytics' section (at the foot of the page), you'll see a drop-down menu for the 'Tracking code'.
Version numbers are not mentioned but if you select 'Global Site Tag (gtag.js)' (and enter your 'Web property ID' above it), the code which is entered into your Showkase pages exactly matches the code shown on Google's own 'Google Analytics 4' support page here.

(Showkase still supports the older version of Google Analytics, too. Just select 'Legacy (ga.js)' from the drop-down menu for the 'Tracking code'.)

I hope this helps to answer your query.

14

(2 replies, posted in Showkase Support)

Update:

For anyone reading this thread, here's a quick update.
The problems were web-server related (issues with permissions, .ini files and file-management tasks).
Migration from a Windows server to a Linux server has resolved the problems and Showkase is running smoothly once again.

15

(2 replies, posted in Showkase Support)

If everything was working fine but now is not and you have not changed anything yourself, then it sounds like something may have changed on your web server which is causing the problem.
Please check in with your web host to see if they have made any changes to your hosting account recently (e.g. change of PHP version, migration to a different web server, etc.) which might somehow be contributing to the problem. This might give us a clue to the nature of the problem and point us in the right direction.

If you have not already done so, then try running the Showkase setup (in case your web host has moved your site to a different web server).

If running the Showkase setup does not help, then perhaps upgrading Showkase will help.
If you are not already running the latest version of Showkase (v1.7.6), then please try upgrading to see if this helps.
Showkase is kept up-to-date to be compatible with the latest versions of PHP and, but if you are currently using an older version of Showkase and your web host has upgraded the version of PHP on your hosting account, then this might be the cause of the problem and upgrading Showkase may help.

You can find full instructions for downloading the latest version of Showkase and upgrading on the Upgrading Showkase support page.

Even if you are already using the latest version of Showkase (v1.7.6), try going through the upgrade process but with the v1.7.6 files. If there are any missing or corrupt source files within your Showkase site, going through the upgrade process will reinstate them with fresh versions. (Make sure that your FTP program is set to overwrite existing files.)

When upgrading your Showkase site, please be sure to make a complete backup of your existing site first, just in case anything should go wrong and you need to reinstate your original files at a later date. You should not encounter any problems upgrading Showkase but it would be wise to have a backup of your site should anything unexpected happen. Also, if you have made manual customizations to any Showkase source files (or to your theme's custom.css or custom.js files), then please note that they may be overwritten when you upgrade and you'll need a backup in order to reinstate them afterwards.

Please let me know how you get on and if I can be of any further assistance.
Thank you.

16

(5 replies, posted in Showkase Support)

All folders 755 and all files to 644. This works and I think is the best I can do security-wise.

That's fine. These are default values (755 for folders and 644 for files) and Showkase should work fine with them.

With regard to your .htaccess file, Showkase does not require a .htaccess file so try removing it (at least temporarily for testing purposes) to see if this helps.

If it does help but you need to reinstate your .htaccess file for other reasons, then check the permissions of the directory containing the .htaccess file (as well as the .htaccess file itself). Try settings the parent directory's permissions to 755. If the permissions are already 755, then try changing them to something else and then back to 755. (It's worth a shot.)

Otherwise, you might need to ask your web host why your .htaccess file cannot be read (and is preventing other files on your site (your Showkase files) from being displayed.

17

(5 replies, posted in Showkase Support)

I'm sorry to hear that you are having trouble with your Showkase site.
I hope my notes below help.

Checking out the web page you provided a link to, I notice that none of the external CSS and JavaScript resource files are being loaded.
If you try to view one of them directly in a browser (e.g. http://bobsgallery.digido.com/_themes/k … styles.css), you'll see the following error message:

Forbidden
You don't have permission to access this resource.
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

This error message suggests that the permissions on the CSS and JavaScript files are too restrictive.
Please check the permissions of your site's CSS and JavaScript files. (Default permissions of 644 should be fine.)
It looks like all your CSS and JavaScript files are affected so it appears that something might have happened on your web server to have caused this problem.
Ask your web host if they have made any changes to your hosting account recently which might be contributing to the problem.
If they have made a change, then perhaps they can reverse it.

Here are some other suggestions...

First of all, please make a complete backup of your site, just in case anything goes wrong and you need to reinstate your original files at a later date. (Even though the site is not currently functioning, a backup might come in useful if you need to rebuild your site.)

Assuming you can log in and navigate around the interface without any CSS, go yo 'System -> Files' and click 'make writeable' against every entry. This should change the permissions throughout your site and might hopefully resolve your problem.

If you need to rebuild your site, there are a couple of things that you can do to reduce the workload.

(1) You can retain the Showkase settings from your original site by manually copying the following files and folders from your original site to your new site (overwriting the default versions which will be in place after a fresh install).

  • _data/sitedata (folder)

  • _data/themedata (folder)

  • _data/pagesprefs.txt (file)

  • _data/theme.txt (file)

Do not copy the _data/pagesdata.txt file though, as this lists the pages present in each site (which will be different after a fresh install).

If you use a custom logo via an image stored in the library, for example, then you might also like to copy the _library folder from your original site to your new site.

If you have modified any Showakse source files or used the custom.css or custom.js files, then please remember that you will need to reinstate your customized files after a fresh install.

(2) You can import all the pages from your original site (via 'Site -> Import') to avoid having to recreate all your pages from scratch. You can import multiple pages at once so recreating your original site should be relatively quick and easy. (You'll need the page folders from your backup to do this.)

Just in case you need a new Showkase-Pro download link, I've emailed you a new one so you can downland the latest version (v1.7.5).

Having said al of the above, it looks like all the CSS and JavaScript files are in their correct locations on your web server but just not being loaded due to a permissions problem.
I am hopeful that your web host will be able to help you fix the problem quickly and without too much effort.

If you run into any difficulties trying to explain things to your web host, just ask them why trying to view this file: http://bobsgallery.digido.com/_themes/k … styles.css
... results in an error 403 when this has not always been the case and what might have caused this problem (as I'm quite you you didn't go changing permissions on all CSS and JavaScript files manually yourself).

I hope my notes help and point you in the right direction.

18

(8 replies, posted in Showkase Support)

I'm glad you're making good progress. Thank you for letting me know!

19

(8 replies, posted in Showkase Support)

I am not the author of Showkase (and I don't make design decisions) but please feel free to post suggestions in the Feature Requests forum thread.
This keeps all the ideas together and ensures that they are not overlooked by the developers.
I do not know the likelihood of any ideas being implemented in future versions but this is certainly the best place for all ideas.
Thank you.

Also, please bear in mind that the 'Basic' page type is really just a blank slate and allows a lot of flexibility as you can put whatever you like on the page. As well as adding text and images via the editor's toolbar, you can switch the editor to source mode (click the 'Source' button) and add whatever HTML code you like.

20

(8 replies, posted in Showkase Support)

Gallery Title is one of the few options supported by Juicebox-Lite, hence its inclusion in the 'Lite Viewer Options' section.

You can find a list of all Juicebox configuration options (and check which headings they come under) in the Juicebox Configuration Options page.

21

(8 replies, posted in Showkase Support)

I'm glad that you have found a way to resolve your problem but there is an easier way to remove a Juicebox gallery title (from within the Showkase interface) without the need to edit the gallery in JuiceboxBuilder-Pro and re-import the gallery into Showkase.

Edit your Juicebox gallery page in Showkase (on the 'Pages' tab).

Now, either:
(1) Scroll down to (and expand) the 'Lite Viewer Options' and delete the 'Gallery Title'.
... or:
(2) Scroll down to (and expand) the 'General (Pro)' section and set 'Gallery Title Position' to 'None'.

Now, scroll back up to the top of the page and click 'Save' and then 'Publish'.

If you still see the gallery title after doing this, then the problem is likely to just be a browser caching issue and clearing your browser's cache before reloading your gallery's web page should resolve the issue.

22

(1 replies, posted in Showkase Support)

Thank you for purchasing Showkase-Standard and Juicebox-Pro.
I'm sorry that you've had such trouble setting up Showkase on your web server.
I'm glad to hear that you've got it working, though.

Showkase requires PHP 5.2.0 or later and will run just as well on PHP 5.2.17 as it will on PHP 7 (or later).
I would always recommend running the most recent versions of any software though, so you might like to try changing your version of PHP to the latest that your web host provides (for the bug and security fixes that more recent versions bring).
Assuming that there are no odd configuration changes that go along with the version change on your web server, you should notice no difference in the functionality of Showkase under PHP 7.0 or later. I've tested Showkase under the latest version of PHP (8.0.1) myself without any issues.
Having said that, if everything is working fine at the moment, then I understand if you are reluctant to change your PHP version and you might want to just leave things as they are.

As you have purchased Showkase-Standard and Juicebox-Pro, you can upgrade your Showkase site to use your Juicebox-Pro files (so that all Juicebox galleries within your Showkase site are Pro) by following the Installing Juicebox-Pro instructions here.
It's just a case of replacing a single folder on your web server and then republishing your Showkase site (full instructions in the link above).

Once you have done that, you'll have the option of either:
(1) Creating Juicebox-Pro galleries directly on your web server from within the Showkase interface.
... or:
(2) Creating Juicebox-Pro galleries on your computer using JuiceboxBuilder-Pro and then importing them into your Showkase site afterwards.

#1
Here are instructions on how to create a Juicebox-Pro gallery page in Showkase: https://www.showkase.net/support/#getting-started

#2
You can find out more about JuiceboxBuilder-Pro in these two links.
JuiceboxBuilder-Pro Tour: https://www.juicebox.net/tour/juiceboxbuilder/
JuiceboxBuilder-Pro User Guide: https://www.juicebox.net/support/juiceboxbuilder/

Here are instructions to import a gallery (created by JuiceboxBuilder-Pro) into your Showkase site using Showkase's 'Site -> Import' functionality.

(1) Create a Juicebox-Pro gallery on your computer with JuiceboxBuilder-Pro.
(2) Upload the complete gallery folder to your web server using an FTP program (such as Filezilla). (I recommend uploading it to a location outside your Showkase directory if possible, just to keep things separate from each other.)
(3) Go to 'Site -> Import' in your Showkase site.
(4) For the 'Import path', enter the path to the directory containing the gallery folder (not the gallery folder itself) starting with a leading slash '/' to denote your root directory.
(5) Click 'Scan' and choose the gallery folder (or folders - you can import several galleries at once if they are all in the same parent directory).
(6) Click 'Import' and 'Publish'.

Once a gallery has been imported, it becomes a genuine Showkase page (just as if the gallery had been created in Showkase itself) and it can be edited from within the Showkase interface if necessary.

For example, if you have created a gallery on your computer with JuiceboxBuilder-Pro and have saved the gallery to a folder named 'my_gallery', try uploading the complete gallery folder to your root directory (via FTP).
Then, in Step #4 above, just use a single slash / as your import path.
After clicking 'Scan', Showkase will look for all valid Juicebox gallery folders and Showkase page folders (Showkase can import Showkase pages as well as Juicebox galleries) in your root directory.
Your 'my_gallery' Juicebox-Pro folder should be listed and you can select it (with its corresponding checkbox) before clicking 'Import' and 'Publish'.

You can upload your gallery folder to anywhere you like on your web server as long as the import path (pointing towards the directory containing the gallery folder) is correct.
I just used your root directory in the example above for convenience.

Just to clarify, Showkase can be installed only on a web server (it is not a regular desktop computer program) and JuiceboxBuilder-Pro can be installed only on a desktop computer (and not on a web server).

I hope this helps.
Please let me know if you have any further queries and I'll do my best to answer them for you.

23

(12 replies, posted in Showkase Support)

You're welcome! I'm glad I was able to be of some help.
I hope you get on well with your customizations.

24

(12 replies, posted in Showkase Support)

Changing the maximum site width should cause no problems at all. The only thing to bear in mind is that if you increase the site width, then on high resolution screens, your galleries will appear larger than they would if the site width was restricted to the default maximum width of 1024px and you might have to use large images in your galleries to compensate (and potentially avoid having too much empty space surrounding your images). It sounds like you've got this covered, though, so increasing your site width should be absolutely fine. (Also, it's something that you can do quickly and easily and it's very easy to change back if you don't like the way things look.)

25

(12 replies, posted in Showkase Support)

I am viewing the "images" tab on the page in Showkase and there it shows the pixel dimensions of the photo. I understand that is not necessarily the size it is displaying, but I am guessing the largest size it will show when possible (without pixelating)

If there are multiple different sizes associated with an image, then the dimensions shown on the 'Images' tab are those of the medium images. There may or may not be large and small size images, too, but there will always be a medium image and it is always the medium image whose dimensions are shown. For clarity, the medium image is the image directly inside the corresponding gallery's 'images' folder (i.e. not inside the 'large' or 'small' folders).

Also, when I say there is always a medium image, this is just a label. The medium image could, in theory, be the only image size being used but it could actually be a very large image (in terms of both filesize and resolution) if you want.

Under most circumstances (check the Multi-Size Image support page for details), it will be the medium image which is used for the gallery display and, if there is a corresponding large image, the the large image will be used if the image is opened in a new tab (via the 'Open Image' button), downloaded (via the 'Download' button) or if the gallery is expanded. (If there is no large image, then the medium image will be used for all occasions.)

Whatever image is displayed in the gallery, it will be dynamically scaled (at the time the gallery is displayed) according to the value of the Juiecbox-Pro imageScaleMode configuration option.
A short description of this configuration option and all its possible values can be found in the 'Main Image' section of the Config Options page here.
By default, imageScaleMode is set to SCALE_DOWN whereby images that are too large (in terms of resolution) to fit within the gallery's image area are dynamically scaled down to fit within the gallery's image area whilst respecting the image's aspect ratio and without cropping. Images that are smaller than the gallery's image area are not scaled up (as this would reduce their visual quality). Such images will be displayed at their actual size (perhaps with some space surrounding the images).
You could (if you wanted to), have small images dynamically scaled up to fill the gallery's image area (again whilst respecting the image's aspect ratio and without cropping) by setting imageScaleMode to SCALE (although I would not recommend it for most users).

In looking at the ACQUA demo...

The AcquaPhoto Fashion gallery (for example), is a single image size gallery (there are no large images).
All images in the gallery are 1024 x 640 (except for one which is 1024x648).
In this gallery, imageScaleMode is set to SCALE so, on a large monitor where the gallery's image area is larger than the actual image dimensions, the images are dynamically scaled up to fill more of the gallery's image area than they would if displayed at their actual size. (This accounts for the drop in quality that you see when you expand the gallery on your high resolution monitor.)

It is just a demo gallery but the following changes would be beneficial:
(1) Larger gallery images could be used so that when the gallery is viewed on a high resolution monitor, the images do not need to be scaled up to fill the gallery's image area.
(2) imageScaleMode could be set to SCALE_DOWN to prevent small images from being dynamically scaled up.
(3) Two images sizes (medium and large) could be used so that, when the gallery is expanded, the large images are used instead of the medium images.

With that in mind, please tell me which boxes should remain checked.

I can't really tell you which settings to use. It's a personal decision that only you can make. Different settings are useful for different audiences.
If your target audience is likely to be viewing your galleries on mobile devices, then there's perhaps little point in providing the gallery with large images and setting imageScaleMode to SCALE might actually be useful.
Having said that, it sounds like my three points above referring to the AcquaPhoto Fashion gallery would probably be useful to you, though.

If I will now be needing to upload different size files for each image, will I be better off doing this in a different manner?

If you want to use different image sizes, then it would be best (certainly easiest) to let Showkase resize them for you.
Just make sure your source images are large enough and set your image sizes on the 'Multi-Size Image (Pro)' section.
Showkase will not upscale source images when resizing them during upload. For any given image size (small, medium or large), if an image is already within the maximum dimension bounds ('Max width' x 'Max height'), then the image will just be copied across to the gallery folder without being resized.

I hope these nuggets of information help to put some of the pieces of the puzzle together for you.